Jog X & Y axis without initial homing possible?

All good things Forums Morgan Builders forum Jog X & Y axis without initial homing possible?

Viewing 6 reply threads
  • Author
    Posts
    • #6091
      TheMike
      Participant

      Hi there,

      I want to set up a Morgan style machine and right now want to check the motors, drivers, board, firmware-software communication etc.

      I´m using an arduino Mega 2560, Arduino 1.06, Ramps 1.4 and A4988 drivers. I still do not have any endstops and I would like to run the Marlin armlevel firmware.

      Is it possible to override the Morgan homing sequence? Is there an gcode command for manually setting (defining) the approximate angles? I know, accurate calibration is needed for good results, but I just want to jog around without preliminary homing…
      I might it be needed to define startup angles in the firmware?

      Highly appreciating your help,
      Mike

    • #6092
      Quentin Harley
      Keymaster

      You can fool the firmware in believing that it homed by quickly after issuing the home command (G28) shorting x-max, y-max z-max in quick succession.

      The firmware will believe it has homed.

    • #6095
      TheMike
      Participant

      Dear Quentin,
      thanks for help, I will try tomorrow !

      Kind regards,
      Mike

    • #6096
      Quentin Harley
      Keymaster

      You can after homing turn off the motors in pronterface, and manually move the arms to the home position for an approximation of the morgan movements

    • #6097
      TheMike
      Participant

      Hi,

      unfortunately I had no success.
      After connecting with Pronterface I set heaters off, pushed on homing button and shorted the x-,y-,z-max subsequently.

      Here´s the serial output:


      Reset.
      Setting hotend temperature to 0.000000 degrees Celsius.
      Setting bed temperature to 0.000000 degrees Celsius.
      X:-115.96Y:-28.84Z:210.00E:0.00
      SCARA Theta:112.84 Psi+Theta:211.67
      SCARA Cal – Theta:112.84 Psi+Theta (90):8.82
      SCARA step Cal – Theta:269.57 Psi+Theta:236.08
      Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)
      No movement – Home first…
      X:-115.96Y:-28.84Z:210.00E:0.00
      SCARA Theta:112.84 Psi+Theta:211.67
      SCARA Cal – Theta:112.84 Psi+Theta (90):8.82
      SCARA step Cal – Theta:269.57 Psi+Theta:236.08

      Perhaps it´s because of unknown errors at startup?:

      Connecting…
      start
      Printer is now online.
      echo: External Reset
      Marlin 1.0.0
      echo: Last Updated: May 31 2015 13:03:02 | Author: (qharley, Morgan SCARA armlevel)
      Compiled: May 31 2015
      echo: Free Memory: 3600 PlannerBufferBytes: 1232
      echo:Using Default settings:
      echo:Steps per unit:
      echo: M92 X215.00 Y215.00 Z100.00 E450.00
      echo:Scaling factors:
      echo: M365 X1.00 Y1.00 Z1.00
      echo:Maximum feedrates (mm/s):
      echo: M203 X300.00 Y300.00 Z300.00 E45.00
      echo:Maximum Acceleration (mm/s2):
      echo: M201 X400 Y400 Z400 E8000
      echo:Acceleration: S=acceleration, T=retract acceleration
      echo: M204 S9000.00 T3000.00
      echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum xY jerk (mm/s), Z=maximum Z jerk (mm/s)
      echo: M205 S0.00 T0.00 B20000 X10.00 Z10.00 E5.00
      echo:Home offset (mm):
      echo: M206 X0.00 Y0.00 Z0.00
      echo:PID settings:
      echo: M301 P22.20 I1.08 D114.00
      Error:0
      [ERROR] Error:0

      : Extruder switched off. MINTEMP triggered !
      Error:Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)
      [ERROR] Error:Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)

      echo:SD init fail

    • #6098
      TheMike
      Participant

      Sorry…I´m to unexperienced…I somewhere read about the mintemp-error and setted the mintemp in Firmware to “-5”. I was able to fool the homing and now I can jog around !! :-))

      Thanks again,
      Mike

    • #6100
      Quentin Harley
      Keymaster

      Glad you got it going

Viewing 6 reply threads
  • You must be logged in to reply to this topic.