Help with X and Y axis

Hold your idea in your hand Forums Morgan Builders forum Help with X and Y axis

Viewing 1 reply thread
  • Author
    Posts
    • #6897
      DoubleD
      Participant

      Hi,

      i have just built my own Morgan but have run into some problems with my config. I can get the Z axis to operate and Home and when the extruder is at temperature I can move the extruder stepper.

      The only way I can get the X and Y axis to move in Marlin is when I hit the home all axis button in Pronterface or if I run G28 (they only move a short distance, once either one of the axis hit an endstop, after multiple hits of the g28 command, they stop moving totally even when you hit g28 again).

      I checked all my end stops and they are working when I run m119 they all say triggered or open when triggered or not

      My x and y run on drv8825 which only has a jumper in MS3 for 1/16th and my z and e are running on a4988 which has jumpers in all 3 for 1/16th

      I don’t believe there is a problem with the hardware as all motors move when I run the RAMPS1.4 TestCode.pde.

      My Configuration.h file is posted here on the reprap forum http://forums.reprap.org/read.php?4,732888

      Please help, not sure where to start looking…

    • #6920
      DoubleD
      Participant

      Anyone maybe know where I can start looking for the problem? Really struggling to find where the problem lies.

Viewing 1 reply thread
  • You must be logged in to reply to this topic.